Magento 2.3 dan dibawahnya

Saat ini server Shared dan Cloud hosting sudah diupdate ke MariaDB versi 10.5. Karena saat ini Magento tidak mendukung MariaDB versi 10.5, Anda akan menerima error seperti ini:

Error: The selected version 2.3.6 is not compatible with the selected install location.Requirements:mariadb 10.2-10.3.99 (detected: 10.5.12)


Untuk mengatasi error tersebut, ikuti langkah-langkah berikut ini:

Langkah ke-1: Install Magento secara manual

Ikuti tutorial install Magento di artikel ini: Cara Install Magento secara Manual.

Langkah ke-2: Edit file konfigurasi

Setelah instalasi selesai, buka direktori app/etc → klik dua kali pada file di.xml

Pada file di.xml, temukan baris ini:

<item name="MariaDB-(10.2-10.4)" xsi:type="string">^10\.[2-4]\.</item>


Ganti baris di atas dengan baris ini:

<item name="MariaDB-(10.2-10.5)" xsi:type="string">^10\.[2-5]\.</item>

Lihat tampilan barisnya di sini: Update file di.xml untuk menggunakan MariaDB 10.5.x #33111

Selesai! Setelah klik Simpan, website Magento akan bisa digunakan.

CATATAN:

  • Perbaikan permanen Magento akan segera dirilis. Untuk saat ini, gunakan langkah-langkah di atas untuk install Magento.

  • Magento Commerce 2.3 dapat digunakan hingga April 2022. Setelah itu, Magento 2.3 dan versi sebelumnya tidak direkomendasikan untuk digunakan. Selengkapnya: Lifecycle policy Magento

Magento 2.4 dan diatasnya

Opsi ini hanya tersedia dan dapat digunakan di paket VPS karena adanya syarat Elasticsearch.

Apakah Anda menemukan jawaban?